Support Center

Recent questions

About Koken

This Help Center provides support for Koken, a free content management system designed for photographers, artists and designers.

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Permalinks

Nick

Oct 23, 2014 02:46PM EDT

Hello, I just installed Koken and the first thing I noticed is the /index.php after the site url. It doesn't look nice. In Wordpress, for example, you don't get that /index.php trailing after the url, which is very nice and therefore easier to remember urls, more user friendly. Or does this have to do with the .htaccess configuration?

Thanks

Up 0 rated Down

Nick

Oct 23, 2014 03:05PM EDT
P.S. Currently running on ubuntu 14.04 and apache2.
Up 0 rated Down

Nick

Oct 24, 2014 08:03AM EDT
After digging around on StackOverflow, I found the answer - http://stackoverflow.com/questions/9608366/remove-index-php-from-url-with-htaccess

Very good advice!
Up 0 rated Down

Todd Dominey Koken Agent

Oct 29, 2014 01:09PM EDT

For anyone else reading this, this is something that is typically handled by your hosting provider. If you’d rather not be editing server files, we recommend contacting your host for help. We have a help topic on why this happens here:

http://help.koken.me/customer/portal/articles/1678459-site-links-include-index-php

Up 0 rated Down

Nick

Oct 30, 2014 07:27AM EDT
Hi, I've finally found the solution. Yes, you were right, I just had to enable mod_rewrite by doing this -

a2enmod rewrite
service apache2 restart

Here's a very good article - https://www.digitalocean.com/community/tutorials/how-to-set-up-mod_rewrite

This question has received the maximum number of answers.

support@koken.me
http://assets1.desk.com/
false
koken
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete