Support Center

Recent questions

About Koken

This Help Center provides support for Koken, a free content management system designed for photographers, artists and designers.

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Koken Lightroom publish plugin error

Vladimir

Aug 22, 2014 12:35PM EDT

I have same issues with Koken Lightroom publish plugin.
When I pushing "Publish Now" button LR5 write en error: "An internal error has occurred: AgExportSession:recordRemoteCollectionId: remote ID must be a number or string"

OSX 10.9.4
LR 5.6
Plugin version - 1.2.6
Koken version - 0.17.3

Up 0 rated Down

Alex

Aug 22, 2014 02:59PM EDT
yes , also problem with latest plug-in , had older version which seems was working find
the error : " [string KokenAPI.Lua]:214 attempt to index field id (numeric value) "
( the error happens when removing deleted image - but maybe in some other cases too )
Up 0 rated Down

Martin

Aug 29, 2014 05:29AM EDT
i have exactly the same problem
Up 0 rated Down

Team NetObjects Koken Agent

Aug 29, 2014 11:24AM EDT

Please try updating to 1.2.7 (just released) and see if that fixes the issue.

Up 0 rated Down

Vladimir

Aug 29, 2014 12:09PM EDT
I've update a plugin to current version - not fixed, still have error
Up 0 rated Down

Martin

Aug 29, 2014 02:15PM EDT
Same for me, the error is still there:

„AgExportSession:recordRemoteCollectionId: remote ID must be a number or string“

OS X 10.10
LR 5.6
Plugin version - 1.2.7
Koken version - 0.17.3
Up 0 rated Down

David

Oct 05, 2014 06:49AM EDT
Same error for me:
"AgExportSession:recordRemoteCollectionId: remote ID must be a number or string"

Windows 7
LR 4.4
Koken Plugin: 1.2.8
Koken Version: 1.8.2
Up 0 rated Down

Frederic

Nov 06, 2014 03:16PM EST
Same errors here (this is the error log exported from the plugin manager in Lightroom):

Plug-in error log for plug-in at: /Users/frederic/Library/Application Support/Adobe/Lightroom/Plugins/koken.lrplugin

**** Error 1

Die Nachbearbeitungsaufgabe dieses Zusatzmoduls konnte nicht erfolgreich abgeschlossen werden.
AgExportSession:recordRemoteCollectionId: remote ID must be a number or string

**** Error 2

Die Nachbearbeitungsaufgabe dieses Zusatzmoduls konnte nicht erfolgreich abgeschlossen werden.
AgExportSession:recordRemoteCollectionId: remote ID must be a number or string

**** Error 3

Die Nachbearbeitungsaufgabe dieses Zusatzmoduls konnte nicht erfolgreich abgeschlossen werden.
KokenExportServiceProvider.lua:596: attempt to concatenate field 'id' (a nil value)



Mac OS X 10.9/10.10
Koken plugin: 1.2.8
Koken version: 0.18.3
Lightroom 5.6
Up 0 rated Down

Rupert Laycock

Nov 09, 2014 07:02PM EST
Yep, I'm getting the same errors.

OS X 10.10
Koken plugin: 1.2.8
Koken version: 0.18.3
Lightroom 5.6
Up 0 rated Down

Elkhan

Nov 11, 2014 05:35AM EST
Seems related.
I created a Set, an Album and put an image inside Album. Pressing Publish gives error - An internal error has occurred: [string "KokenAPI.lua"]:243: attempt to concatenate field 'album' (a nil value)
These Set, Album and Image are not added to Koken installation.
Up 0 rated Down

Joshua

Dec 16, 2014 12:29PM EST
Same issue here...

OS X 10.10.1
LR 5.7
Plugin 1.2.8

Can't Publish or Export (seeing the same error messages shown previously in the thread).

Only other wrinkle: Connecting to a url with https.
Up 0 rated Down

Steph

Feb 05, 2015 04:56PM EST
Same as Joshua.

No fix, I guess Koken is dead.
Up 0 rated Down

Adam

Feb 14, 2015 09:11PM EST
Is Koken still going? Lead guy left and no fixes for this issue for months, too bad was cool software.
Up 0 rated Down

Jonathan

Feb 18, 2015 05:59AM EST
Hi, same trouble here with this message coming up every time :
“Une erreur interne s'est produite : [string "KokenExportServiceProvider.lua"]:596: attempt to concatenate field 'id' (a nil value)“

OS X 10.10.1
Lightroom 5.7.1
Koken 0.20.1
Up 0 rated Down

Team NetObjects Koken Agent

Feb 18, 2015 11:55AM EST

These sort of errors usually indicate some sort of communication error between Lightroom and Koken, but we had some holes in our error handling that caused the cryptic errors you all have been seeing (sorry about that).

If you are having this issue, please try the latest update of the Lightroom plugin, as we’ve released some improved error handling that should at least give more indication where the actual error is coming from.

Up 0 rated Down

Team NetObjects Koken Agent

Feb 24, 2015 11:22AM EST

We believe we have resolved this issue in Koken 0.20.3. Please try it and let us know if it fixes the problem for you.

Up 0 rated Down

David

Feb 24, 2015 02:59PM EST
Hi Brad, I have still some issues her. Above I reported the first time on Okt 5, 2014 and send you a detailed mail on Okt 13, 2014. I just updated to Koken 0.20.3 and Lightroom Plugin 1.2.10 on Win7 and Lightroom 5.7. Koken is hosted at a server of www.all-inkl.com.
Retrieved this message in german: "Diese Sammlung kann nicht aktualisiert werden. Ein interner Fehler ist aufgetreten: [string "KokenExportServiceProvider.lua"]:609: attempt to concatenate field 'id' (a nil value)".
Translated loosly by myself: "This collection could not be udpdated. An internal error occured: [string "KokenExportServiceProvider.lua"]:609: attempt to concatenate field 'id' (a nil value)".
If you need some help reproducing the error feel free to contact me.
Regards, David
Up 0 rated Down

David

Feb 24, 2015 03:04PM EST
Some additional information: In my previous post I tried to update an existing album. Now I tried to create a new one and I retrieved a different error message but the same one as in oktober: "AgExportSession:recordRemoteCollectionId: remote ID must be a number or string"
Hope that helps. Thanks for your great work!
Up 0 rated Down

Peter

Feb 27, 2015 02:22PM EST
Same problem, using LR 5.6 on Mac OS X 10.10.2
Koken 0.20.3
Koken LR plug-in 1.2.10

An internal error has occurred:
[string "KokenExportServiceProvider.lua"]:609: attempt to concatenate field 'id' (a nil value)
Up 0 rated Down

Team NetObjects Koken Agent

Feb 27, 2015 03:32PM EST

If you are still having issues like these, please send us the URL, email and password for your Koken install so we can take a look. support[at]koken.me

Up 0 rated Down

David

Mar 02, 2015 02:47PM EST
Hy Brad,
I just setup a test instance of koken to give you access to for investigating in this bug. To be sure the bug could be repruduced on the test account I checked the lightroom upload and it worked... Wondering why I tried the publishing again with the live installation but the error occured again. Then I created a new publishing service instance in lightroom for the live system and this worked!
So something must be incorrect in the old publishing service instances in the lightroom catalog. After update to lightroom plugin 1.2.10 I was NOT asked to update the lightroom catalog, if I remember correctly. The API on the server seems to work properly.
If you need further help, don't hesitate.
Regards, David

This question has received the maximum number of answers.

support@koken.me
http://assets2.desk.com/
false
koken
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete