Support Center

Recent questions

About Koken

This Help Center provides support for Koken, a free content management system designed for photographers, artists and designers.

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

nginx, error looback connection.

Ugo

Jan 17, 2018 09:04PM EST

Hi,

I know this question was already asked, but I could'nt find any answer to it.

So : I have a Koken server (docker) on my dedicated server, and my connections are handle by nginx + LetsEncrypt (also docker). To ensure a minimun of security.

But since I've the second layer, aka my ssl connection, Koken return me "API Error
The theme is not able to make contact with your Koken installation. Contact your host to see if they are blocking loopback connections"
But I can still manage trugh the */admin page.
And all my other services are avaible and work properly.

I've try everything, I've found, on this subject. But nothing worked.

Can you help me ?

By the way, all the config and data file, are separate from my docker images. I use docker just to manage the static parts of my web services.

Up 0 rated Down

Team NetObjects Koken Agent

Jan 18, 2018 08:29AM EST

Hello,

Have you edited the .htaccess file to use HTTPS? Connect to your server via FTP. Open the .htaccess file in a text editor. At the top of the file are instructions about activating https for admin pages. You can also change to / instead of /admin/ so it works for the whole site. Here’s what it should look like:

  1. Uncomment the following block to force SSL when accessing /admin
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_URI} /
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
Up 0 rated Down

Ugo

Jan 18, 2018 11:43AM EST
Yes, I've done this.

It's one of the first thing I've done.

When I enable these lines, I can't acces anymore to */admin page. And the main page return me the same error than before.
Up 0 rated Down

Team NetObjects Koken Agent

Jan 18, 2018 11:46AM EST

Please clear the system caches in Settings / System then connect to your server via FTP and deleted the storage/cache/api and storage/cache/site folders.

This question has received the maximum number of answers.

support@koken.me
http://assets2.desk.com/
false
koken
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete