Support Center

Recent questions

About Koken

This Help Center provides support for Koken, a free content management system designed for photographers, artists and designers.

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Unable to login to admin after fresh install

Josh

Apr 10, 2017 11:37PM EDT

Just installed Koken on a fresh install of Ubuntu 16.04 LTS. Install completes successfully but I can't get past the admin login unless I check the "keep me signed in" box. Once I login with that checked, I just get a blank, black screen with some unclickable links at the top.

Google developer console shows these errors:

GET http://koken.alderaan.pw/api.php?/plugins/cache:false 401 (Unauthorized)

Uncaught TypeError: Cannot read property 'length' of undefined
at Object.finished (koken-core.js:3045)
at Object.r.request.length.e.request.length.n.success (koken-core.js:891)
at j (jquery.min.js:2)
at Object.fireWith [as resolveWith] (jquery.min.js:2)
at x (jquery.min.js:4)
at XMLHttpRequest.<anonymous> (jquery.min.js:4)

POST http://koken.alderaan.pw/api.php?/settings 401 (Unauthorized)

GET https://store.koken.me/installs//updates 500 (Internal Server Error)

XMLHttpRequest cannot load https://store.koken.me/installs//updates. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://koken.alderaan.pw' is therefore not allowed access. The response had HTTP status code 500.

Upon a refresh of the page it redirects back to login.

I read through other similar issue pages to no avail.

1 Community Answers

Answered

Bjarne Varöystrand

Apr 13, 2017 09:54AM EDT

Hi Josh.

From the above it seams as there is more then one thing going on here.

The first thing to ensure is that you have turned of MySQL strict mode, since Koken is not compatible with that yet.
(Ubuntu 16.04 ships with MySQL 5.7 where strict mode is default)

To disable strict mode you can follow the instructions here:
https://kokensupport.com/viewtopic.php?f=8&t=429&p=1953&hilit=strict+mode#p1953
https://kokensupport.com/viewtopic.php?f=3&t=604&p=2939&hilit=strict+mode#p2939

The second issue seams to be related to your CORS settings and that is the error 500 you get

----------------------
Regards, Bjarne
Koken Community Support - http://kokensupport.com/


This question has received the maximum number of answers.

support@koken.me
http://assets3.desk.com/
false
koken
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete