Support Center

PHP 5.2 support warnings are displaying

PHP 5.2 support warnings are displaying

Last Updated: Sep 02, 2014 09:14AM EDT

Summary: As of January 1st, 2015, Koken will no longer support PHP 5.2. Koken will continue to work on servers with PHP 5.2, but those installations will no longer receive updates or server-related support after January 1st.

What is PHP?

PHP is the programming language that much of Koken is written in. It runs on your server and is what allows Koken to render your website, create copies of your images, and perform other necessary functions.

How do I know what version of PHP my install is running?

Sign in to your Koken install, then click Settings in the top navigation. Then click System in the left column. The PHP version is listed on the resulting page.

What's wrong with PHP 5.2

PHP 5.2 is no longer maintained by the PHP team. That means it does not receive any security patches or bug-fixes and also performs much slower than newer versions of PHP. Also, a large number of support requests fielded by the Koken team involve substandard shared-hosting providers that run PHP 5.2. Ending support for PHP 5.2 will allow our team to focus on newer features that can take advantage of the more modern capabilites of PHP 5.3+ while also reducing support overhead.

How do I upgrade PHP?

Upgrading PHP should be done in concert with your hosting provider and/or your system administrator. Many hosting providers already provide a way to change to a newer version of PHP through their hosting control panels. Contact your host or system administrator and request that they update you to PHP 5.3 or later. Koken is compatible with all stable releases of PHP, which currently includes PHP 5.3, 5.4, 5.5, and 5.6. We recommend the latest version your hosting provider has available. If your host is unwilling to update, we maintain a list of suggested web hosts who all run recent versions of PHP.

What will happen if I don't upgrade by January 1st

Koken will continue to work on PHP 5.2 for the foreseeable future. However, if your server is running PHP 5.2 after January 1st, you will no longer be able to update Koken to newer releases. In other words, whatever Koken release is available on December 31st, 2014, will be the last version offered to PHP 5.2 users. We also will not be providing technical support for server-related issues after January 1st for those continuing to use PHP 5.2.

If you have any questions, please contact us.

support@koken.me
http://assets3.desk.com/
false
koken
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete