Support Center

Recent questions

About Koken

This Help Center provides support for Koken, a free content management system designed for photographers, artists and designers.

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

lightroom pluging JSON error

Vasyl Gontar

Aug 25, 2014 11:53AM EDT

I have the latest version of koken and lightroom plugin installed (actually I did a clean install to reproduce the problem).
I am using the latest version of lightroom available as of 25-08-2014.
When I go to Applications and copy the api path into koken account section in lightroom plugin it opens kmy admin interface and allows me to grant access, The token in created and appears in Application section of my koken install.

Then when I click I'm done or whatever it is called in the plug in. I get an error window with:

An internal error has occured: {string "JSON.lua"}:197: nil passed to JSON:decode()

In order to replicate the error I did a clean install of koken, I am still getting the error.
I tried both ssl and non ssl address, I get the eror on both (it is a comodo certificate and not a self signed one).

If it is important I am running apache 2.2 php 5.4.24 mysql 5.6.20 on mac osx 10.9.4.

also I tried from local network and from external. (basically tried with 192.168.0.* adress and with my domain name and with my external ip)

Any ideas on how to resolve this^

Up 0 rated Down

Vasyl Gontar

Aug 25, 2014 11:57AM EDT
Also wanted to mention that after that error the pluging returns to an inconfigured state.
Up 0 rated Down

Vasyl Gontar

Aug 25, 2014 12:17PM EDT
One more thing.
Just tried it on a mac and it works fine.
SO the problem seems to be on windows.
I tried to create a new catalog on a separate disk just to make sure it is not a permission error (my computers are in an Active Directory domain) I am still getting the same error.

My windows machine is win 8.1 in a domain (now funky group policies and no roaming profiles).
The catalog and photos are located on a separate disk (internal) and that disk is linked in windows as My Pictures folder.
Up 0 rated Down

Team NetObjects Koken Agent

Aug 25, 2014 12:39PM EDT

Any firewalls on the Windows machine that may be blocking the outgoing connection?

Up 0 rated Down

Vasyl Gontar

Aug 25, 2014 01:04PM EDT
port 80 to my domain or something else?
Up 0 rated Down

Vasyl Gontar

Aug 25, 2014 01:09PM EDT
Nevermind I found it ...
It was a firewall rule.

Thanks for the help.
Up 0 rated Down

Vasyl Gontar

Aug 25, 2014 01:11PM EDT
Just to elaborate,
Our default group policy on AD is to block all outgoing communication except allowed by admin.

Guess what ... lightroom was not whitelisted.

This question has received the maximum number of answers.
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
Invalid characters found